DNS Outage
Incident Report for Spirit
Resolved
This incident has been resolved.
Posted Jul 17, 2020 - 17:50 EDT
Monitoring
Cloudflare appears to be back online. We will continue to monitor this issue.
Posted Jul 17, 2020 - 17:38 EDT
Identified
Cloudflare is currently experiencing a global outage, which is effecting millions of websites and companies. We are included in the effected companies. Cloudflare are investigating the issue and we will post an update here when the issues have been resolved.
Posted Jul 17, 2020 - 17:28 EDT
This incident affected: Web App, Web Admin, Logon Service, and Spirit CDN.