Spirit System Outage
Incident Report for Spirit
Resolved
This incident has been resolved.
Posted Oct 22, 2019 - 23:00 EDT
Monitoring
It appears AWS is back online. We will continue to monitor this issue.
Posted Oct 22, 2019 - 21:11 EDT
Identified
Our third-party cloud provider, Amazon Web Services, (they run our website) is experiencing a worldwide outage. Several thousand companies are affected. Images and web pages may not load properly. We'll keep this page updated as we receive information.
Posted Oct 22, 2019 - 19:55 EDT
This incident affected: Spirit CDN.